Skip to main content

☑️ Prevent use of removed APIs in Kubernetes v1.27

Kubernetes version 1.27 stopped serving several APIs for different resource types.
When deploying a resource with a removed API version, the Kubernetes engine will reject it.

The following resources are removed in version 1.27:

API versionResource kind
storage.k8s.io/v1beta1CSIStorageCapacity

Targeted objects by this rule (types of kind): (See table above)

Complexity: easy (What does this mean?)

Policy as code identifier: K8S_REMOVED_APIVERSION_1.27


This rule will fail​

If one of the removed API versions is used:

apiVersion: storage.k8s.io/v1beta1
kind: CSIStorageCapacity

Rule output in the CLI​

$ datree test *.yaml

>> File: failExample.yaml
❌ Prevent use of removed APIs in Kubernetes v1.27 [1 occurrence]
💡 Incorrect value for key `apiVersion` - the version of the resource you are trying to use is removed in k8s v1.27

How to fix this failure​

Use a supported API version instead of the removed one:

Removed API versionSupported API version
storage.k8s.io/v1beta1storage.k8s.io/v1

Example:

apiVersion: storage.k8s.io/v1
kind: CSIStorageCapacity

Read more​